PINE64

Full Version: Debian Pine64 h264/5 Video under vlc
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello comunity,

I have a rock64-4G under Debian stretch that I would like to use it as a normal computer.
The only problem that I find is the slow play of the >=h264 videos (through VLC).

I've seen how other smaller boards like cubbieboard 2 handle these videos from debian without problem, so I guess in rock64 it should work better.

I think the problem ist in the acceleration driver for the mali GPU, which I think the board has.

It seems that the sources are here:

https://github.com/rockchip-linux/libmal...hip/debian
or here
https://github.com/rock64-linux/libmali/...hip/debian

But I have not idea how to procced... how compile/install

Someone so kind to help me?

Thanks in advance. Regards everyone

Thanks in advance.
(01-14-2018, 12:11 PM)ozcy Wrote: [ -> ]Hello comunity,

I have a rock64-4G under Debian stretch that I would like to use it as a normal computer.
The only problem that I find is the slow play of the >=h264 videos (through VLC).

I've seen how other smaller boards like cubbieboard 2 handle these videos from debian without problem, so I guess in rock64 it should work better.

I think the problem ist in the acceleration driver for the mali GPU, which I think the board has.

It seems that the sources are here:

https://github.com/rockchip-linux/libmal...hip/debian
or here
https://github.com/rock64-linux/libmali/...hip/debian

But I have not idea how to procced... how compile/install

Someone so kind to help me?

Thanks in advance. Regards everyone

Thanks in advance.

The video playback using VPU for acceleration, not GPU.
(01-15-2018, 11:15 PM)tllim Wrote: [ -> ]
(01-14-2018, 12:11 PM)ozcy Wrote: [ -> ]...

The video playback using VPU for acceleration, not GPU.

Thank you for the hint tllim... so the right question is then, How I do to enable the VPU or VDPAU in VLC or smplayer? The first program show no screen, the second restart the xserver

Thanks in advance.
(01-16-2018, 05:01 PM)ozcy Wrote: [ -> ]
(01-15-2018, 11:15 PM)tllim Wrote: [ -> ]
(01-14-2018, 12:11 PM)ozcy Wrote: [ -> ]...

The video playback using VPU for acceleration, not GPU.

Thank you for the hint tllim... so the right question is then, How I do to enable the VPU or VDPAU in VLC or smplayer? The first program show no screen, the second restart the xserver

Thanks in advance.

Here is the info getting from http://linux-sunxi.org/Cedrus/libvdpau-sunxi:

Playing video
With everything setup properly, it should now be possible to playback hardware accelerated media!
The best test file would be one of the well known sample media's. The big buck bunny is an often used one. http://samplemedia.linaro.org/H264/big_b..._7200K.MP4
Depending if you use mpv or mplayer2, the following options are required. For mplayer2:
mplayer -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau, [filename]
For mpv:
mpv --vo=vdpau --hwdec=vdpau --hwdec-codecs=all [filename]
Note: There have been reports that some mplayer versions in certain repositories are not compiled with vdpau support.
Now you can also try to use other files, but note it has to be mpeg1, mpeg2 or h264 encoded!
Hello:
rock 64 4 GB RAM
Debian Stretch Minimal Community Build Image [microSD Boot] by ayufan
XFCE desktop

This does not work for me.
What can I be doing wrong?

$ mpv --vo=vdpau --hwdec=vdpau --hwdec-codecs=all big_buck_bunny_1080p_H264_AAC_25fps_7200K.MP4
Playing: big_buck_bunny_1080p_H264_AAC_25fps_7200K.MP4
(+) Video --vid=1 (*) (h264)
(+) Audio --aid=1 --alang=und (*) (aac)
File tags:
Artist: created with SUPER©.v2011.bld.49
Comment: 09:51:32
Title: big_buck_bunny_1080p_surround.avi_006.AVI.MP4
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vo/vdpau] Error when calling vdp_device_create_x11: 1
Error opening/initializing the selected video_out (--vo) device.
Video: no video


Exiting... (Errors when loading file)


Thanks for help.
Hello:
Rock64 4GB
Debian minimal installed


[email protected]:~/libvdpau-sunxi$ make
make: pkg-config: Orde non atopada
make: pkg-config: Orde non atopada
cc -MD -MP -MQ device.o -fpic -fvisibility=hidden -Wall -O3  -c device.c -o device.o
In file included from device.c:24:0:
vdpau_private.h:33:20: fatal error: pixman.h: There is no such file or directory
 #include "pixman.h"
                    ^
compilation terminated.
Makefile:47: recipe for target 'device.o' failed
make: *** [device.o] Error 1
[email protected]:~/libvdpau-sunxi$ ls /usr/local/include/pixman-1/
pixman.h  pixman-version.h


I installed all prerequisites
    git (yum install git | apt-get install git | emerge git)
    gcc (yum group-install "Development Tools" | apt-get install build-essential)
    libvdpau-dev >= 1.1 (yum install libvdpau-dev | apt-get install libvdpau-dev | emerge libvdpau) or build from source
    libcedrus (https://github.com/linux-sunxi/libcedrus)
    pixman (http://www.pixman.org)

Any idea that error not found file:
#include "pixman.h"
?



Thanks.

PD. I thought it would be interesting to put an image (ayufan) of debian with this already installed.