PINE64

Full Version: How can I reliably get battery status on pinebook
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

thanks to the great Q4os developers I now have a quite decent Debian Stretch system running.  After I managed to flash the eMMC with Q4os I simply editet sources.list to point to Stretch instead of Jessie and did a dist-upgrade.   I needed to fiddle a bit with the graphics since X was lost but rebuilding libump and xf86-video-fbturbo under Stretch did the trick.  (I'm a Debian developer and might consider creating at least an official libump package - need to check the license of fbturbo whether it is acceptable in Debian.)

I now try to get some reliable information about the battery status.  I'm using xfce4 but the battery plugin always says the battery is empty (even if I get a desktop notification that the battery is full when plugging in power adapter.

The command acpi does not work.

How do others check the battery status on pinebook?

Kind regards

        Andreas.
Does q4os also have the 'sudo pine64_health.sh' script? Because there you can see it reliably.
(09-19-2017, 02:00 PM)joekinley Wrote: [ -> ]Does q4os also have the 'sudo pine64_health.sh' script? Because there you can see it reliably.

If it doesn't have that script, you can download it from here. Or if you just want battery info, you can use this script that I wrote. I run it on the pinebook with using a screenlets terminal widget to have it stuck on the desktop for when I'm testing stuff and want to seem some more stats than just 'how charged / how flat' is the battery. Wink ACPI doesn't work on the pine64/pinebook as ARM doesn't have ACPI... instead you query the '/sys/class/power_supply/battery/' path for current usage, voltage, and charging or discharging, and percentage charge.
Code:
[battery]
label=
command=tail "/sys/class/power_supply/battery/capacity"

I add this to my i3block cfg file and it is working perfect for me
I run a Debian-based distro also, and 'acpi' and 'acpi -V' would mot work until I installed  it with

'apt-get install acpi'.   [You may have to use 'sudo apt-get install acpi']

'acpi -V' (note the space) is the "verbose" version, which also gives you the current health of your battery, i.e., percentage capacity now vs. original design (new) capacity. Great command-line utility to have.