PINE64

Full Version: Strange OpenSSL RSA speed Test issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi guys,


i require your helps and ideas.

i run openssl speed rsa to evaluate the power of my PINE64+ board (i am a crypto guy).



i was a litle bit surprised to see big difference using different distribs :

 - the Debian Jessie with Mate DE [3.10.102 BSP 2] by Lenny Raposo    show me a nice 9.6 4096bits Private RSA / sec



while other dietPI and armbian get stuck to 6.4 4096bits Private RSA / sec.



So i decide to upgrade both the Debian Jessie Mate and dietPI to the latest kernel 3.10.105, run package update, then i force the CPU setting got from the debian to the dietPI :

sampling_down_factor = 1

sampling_rate = 2000000

sampling_rate_min=40000

up_threshold = 95



but got same result dietPI still show me  6.4 4096bits Private RSA / sec.

What do i miss ?


Any helps appreciate, thanks a lot
Check what scaling govenor is being used on the DietPi?

Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

It has been set as interactive for a long time on the pine64 images... I think DietPi was a bit daft at one point and had it set at ondemand... maybe it still is? Also see what happens to your benchmark when you change it to performance.

Code:
sudo -i
echo performance> /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
exit
It was set to 'ondemand',
but your proposal to set it to 'performance' is what i might have done first, 
and now i know that the cpu scaling is not the key :-(
all cpu clock set to 1152Mhz ...give same openssl rsa speed measure : 6.4 :-(   on the dietPi