No Android build working!
#51
(10-23-2020, 05:41 AM)rempfer Wrote: Would you have a link to the "specific img" perchance?  Thanks.

This one: http://files.pine64.org/os/PinebookPro/A...oot.img.gz

The wiki denotes that use of rkflashtool is required to boot it, but it isn't. Just write that to an SD and get settled in for the boot. This image takes minutes to boot up the first time, but is noticeably faster booting subsequent times.
  Reply
#52
I'd like to add I'm one of those trying to boot Android 7.1 (as downloaded through the Wiki link) from the SD card. I flashed it using Balena Etcher and when I try to boot my PBP with the SD popped in, it just boots into Manjaro. I haven't gone into such depth as others seem to have gone (and I honestly don't have the knowledge too, yet). I don't think I'd care for version 9 as I only need Android for one little thing so 7.1 would probably be sufficient (if it allows me to install the required app).

One thing I noticed is that Balena does mention that when I choose the Android image (with the proper MD5 sum and decompressed with 7zip), that it is missing the partition table and that it won't be bootable. So it seems to be an issue with the image as at that point I haven't chosen the SD card and also, it doesn't happen for instance with the Ubuntu image (which does boot). I have to mention that I used Balena Etcher in MS Windows 10, not on linux.

So yeah, to all those whose Android SD card doesn't boot, haven't you noticed a mention that partition table is missing and that it might not boot? To me this seems to be the problem. I hope now that there is someone who can find the solution to this Smile.
  Reply
#53
I recall having to do nothing to get it to work. Oddly it was just about the only thing I could get to work at the time. I don't use etcher though. Maybe I was using an older version than what you've found, I have no idea.

Using Android on SD though, hosed my eMMC. It's like Android just wanted to take over the whole system.
  Reply
#54
(11-15-2020, 03:46 PM)KC9UDX Wrote: I recall having to do nothing to get it to work.  Oddly it was just about the only thing I could get to work at the time.  I don't use etcher though.  Maybe I was using an older version than what you've found, I have no idea.

Using Android on SD though, hosed my eMMC.  It's like Android just wanted to take over the whole system.
Oh, that doesn't sound pretty! I'd want it to run on the SD card and stay there. No point accessing anything else on my computer, it is just for running an app I need.
  Reply
#55
I might have done something wrong. So please don't avoid trying it because of what happened to me. But do have a backup of your eMMC just in case.

FWIW, I used `dd` on a computer with NetBSD to create the working SD card. You could use `dd` in Manjaro on your PBP. I don't know the first thing about Etcher. I've heard lots of good things about it, and never heard anything bad about it. But `dd` is the most direct way to do this job. I can't imagine using anything else (in Unix/Linux).

dd if=file.img of=/dev/sd bs=4M status=progress
Should get the job done in Manjaro, I think. Of course, replace "file.img" with the correct image file. If it's zipped, unzip it first. (unzip file.img.bzip) You'll have to replace /dev/sd with the raw device for the SD card. I don't recall the device name for Manjaro; you might already know it. If you don't, let me know and I'll dig up that information.
  Reply
#56
(11-15-2020, 03:35 PM)Vinay Wrote: I'd like to add I'm one of those trying to boot Android 7.1 (as downloaded through the Wiki link) from the SD card. I flashed it using Balena Etcher and when I try to boot my PBP with the SD popped in, it just boots into Manjaro. I haven't gone into such depth as others seem to have gone (and I honestly don't have the knowledge too, yet). I don't think I'd care for version 9 as I only need Android for one little thing so 7.1 would probably be sufficient (if it allows me to install the required app).

One thing I noticed is that Balena does mention that when I choose the Android image (with the proper MD5 sum and decompressed with 7zip), that it is missing the partition table and that it won't be bootable. So it seems to be an issue with the image as at that point I haven't chosen the SD card and also, it doesn't happen for instance with the Ubuntu image (which does boot). I have to mention that I used Balena Etcher in MS Windows 10, not on linux.

So yeah, to all those whose Android SD card doesn't boot, haven't you noticed a mention that partition table is missing and that it might not boot? To me this seems to be the problem. I hope now that there is someone who can find the solution to this Smile.

It was mentioned somewhere in this forum that you can boot Android when you disable eMMC using a switch. I've done it and was able to boot android 7.1. Without disabling eMMC, PBP boots to Manjaro. I've used 'dd' to flash SD card with android image. I cannot mount SD card with Android image flashed in Manjaro.

Other thing is that for me Android image is not useful at all. But this is for another thread.
  Reply
#57
What U-Boot are you using? I would think that has more to do with not booting from SD card than Manjaro.

I expect that the first thing you'll want to do is install one of the non-Google market apps. That should get you closer to what you're probably expecting for usability. Otherwise you might need to install Google Play Services or something like it.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Getting platform tools working like I'm used to? bastafari 20 4,192 12-24-2020, 01:14 AM
Last Post: jonnyhawk
  Google on Android? KC9UDX 15 3,557 11-18-2020, 06:24 AM
Last Post: Vinay
  MD5 On Android jaysistar 0 601 03-14-2020, 08:38 AM
Last Post: jaysistar
  Arguments for android support metcalsr 20 6,757 02-08-2020, 12:12 PM
Last Post: Idaho
Exclamation All android buillds on wiki for Microsd missing GPT? TDC_PBP 14 4,906 01-31-2020, 11:22 PM
Last Post: tophneal
  Any word about Android builds? tophneal 36 12,351 01-26-2020, 12:06 AM
Last Post: Account
  Flashing Updated U-Boot on Android tophneal 6 2,343 01-16-2020, 06:05 AM
Last Post: tophneal

Forum Jump:


Users browsing this thread: 2 Guest(s)