Trackpad firmware update
(02-04-2020, 04:33 PM)bcnaz Wrote:
(02-04-2020, 03:55 PM)Sally Wrote:
(01-15-2020, 05:32 PM)wtdonnelly Wrote:
(01-15-2020, 04:54 PM)Sally Wrote:
(01-15-2020, 03:51 PM)Der Geist der Maschine Wrote: The keyboard firmware sits in a flash within the keyboard. A Debian reinstall will not touch this flash. So, no.

Thank you, understood:  I've tried more times I can't count to solve this issue. From the start I had to enter the password twice before it would take. The last time a powered down (30 minutes ago) I had to power down the Pinebook Pro twice before it accepted. 

cd pinebook-pro-keyboard-updater
sudo ./updater step-2 iso
sudo reboot

Yet the keyboard doesn't type letters out correctly.

I've documented it all. I don't like returning things when I've been waiting impatiently for my Pinebook Pro.This isn't my 1st time a the rodeo, I own the Pinebook. I need instruction how to return and replace my Pinebook Pro. Thanks to every one for your assistance.

My deepest regards.
Lucy

This must be so frustrating for you!  Forgive me if I missed this, but have you tried an external keyboard, and if so, how does that work?

If you could do one more test it may allow us to pinpoint why the keyboard isn't operating as you expect.  Since you did manage to log in, if you could open a text document and just hit each key in each row in order, and then repeat with shift on eg,

`1234567890-=
~!@#$%^&*()_+
qwertyuiop[]\
QWERTYUIOP{}|

asdfghjkl;'
ASDFGHJKL:"
zxcvbnm,./
ZXCVBNM<>?

and then post the results here, it would help us understand what the keyboard *is* doing, and why.

Fingers crossed for you,

Bill

Hello Bill,

Sorry for the delay, have the flu...

1. Yes I can' type when I add my external keyboard, no issues

2. But when I use PineBook keyboard this is what I get.



1. 

1234567 - this number come up after one keys is typed punch 1 you get 2 punch 3 your get 4 and so forth

1234567 - these is with the shift key "ON"

wsedrftyh-j 

wsedrftyh-j - same thing when shift key is "ON"

2. 
qzxcgvbnk

qzxcgvbnk - something when shift key is "On"

a<imo. - something when shift key is "On"

Thank you for your assistance.

Something tells me I'll have to return my pine book before my 31 day warranty runs out. My mother isn't please but I told her it could have a glitch or two. I don't know what went wrong, but I still want a PineBook. Thank everyone for their assistance, I fill confident with a supportive community my experience with PineBook will be just fine. Thank you all again.

Lucy
 ( FEB. 04, 2020 )

Maybe a dumb question :

  Have you set the language in the keyboard settings ?

ie:  EU keyboard for ISO  or  US keyboard for the ANSI keyboard  ?

Yes, I have with no luck.
  Reply
(02-07-2020, 04:26 PM)Sally Wrote: Yes, I have with no luck.

Have you tried updating the updater and trying again yet?
  Reply
Thumbs Down 
I just tried the update, and my pinebook pro is bricked at step 1.

After executing the 'sudo ./updater-step-1 iso' my keyboard is so nonfunctional that I can't even enter the sequence 'sudo reboot'. Characters are now coming back as if there was a completely different keyboard connected to my pinebook.

Argh. What can I do now to restore the keyboard to remote functionality? This is super upsetting.
  Reply
Fixed my own problem: plugged in an external USB keyboard and trackpad, rebooted, opened a term window, moved to the right directory and entered 'sudo ./updater step-1 ansi', rebooted, then 'sudo ./updater step-2 ansi', rebooted, and all is good.
  Reply
Like, say, specified on the Wiki ?
  Reply
See my post at https://forum.pine64.org/showthread.php?...8#pid60238 which is sort of in a backwater. Turn off the Synaptics and mtrack drivers, just use libinput.
  Reply
Hello everyone this is Sally.

I'm sorry for the delay but the flue turned out to be walking ammonia. Though I'm not up to par, I've attempted to update the keyboard as instructed and nothings has changed. So any more thoughts or suggestions, I'm open to trying them.

I should say, I've test to review all suggestions because, it takes some effort to due to lack of energy. I had contacted PineBook Inc. and they said they would assist me through this one way or other. Again thanks for your assistance. I'll attempt to comeback one a day for any assistance. 

Thank you.

Sally
  Reply
Hi,

sorry to bother you with this again, but my touchpad is bricked after step-1 . Reading for hours now. Tried everything, ssh, external keyboard etc.

documented the issue at https://github.com/ayufan-rock64/pineboo.../issues/19

Any ideas left?

PBP ISO Manjaro 20 and Default Debian from sdcard
  Reply
Hey guys! Received my PBP few days ago (ordered in January)! Should I apply keyboard update, or it is already applied for new PBPs? Thanks in advance!
(Just wondering because some people experiencing issues when patching)
  Reply
I Believe Luke mentions that somewhere in this thread,
                                  I am not certain,    but I seem to remember he said any PBP   "Built in 2019"

 But,  both my first ISO PBP, and my later ANSI PBP are still running the old firmware, 
                                                                                           and I have not encountered any problems,   YET

SO,  I would say if you do not have any problems, do not worry about it.

IF you Do have a problem,  they do have the fix for it.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Lifting Trackpad p3pp3r 7 2,381 03-23-2021, 05:48 PM
Last Post: Timpanogos Slim
  No keyboard & trackpad leads to no display. RMA from the US. Free parts in Seattle BitterPine 4 1,487 12-30-2020, 06:14 AM
Last Post: BetteHoward
  Safe to Update? BluBombr64 6 1,030 12-18-2020, 11:59 AM
Last Post: BluBombr64
Bug [Fixed] Issue with mesa-git (Manjaro ARM Stable Update 2020-09-22)) JasonG-FR 20 5,361 12-12-2020, 05:09 AM
Last Post: mogwai
  For sale: Pinebook Pro from the first batch, with the 128 Gb update Linux-Rob 8 3,114 10-07-2020, 12:03 PM
Last Post: Linux-Rob
  Proper way to use mrfixit update bastafari 13 3,181 09-29-2020, 09:45 PM
Last Post: wdt
  Do I need the touchpad update? Paulie420 3 1,292 09-22-2020, 06:40 PM
Last Post: Paulie420
  brick after firmware update on emms sashka_amur 4 1,301 09-22-2020, 02:24 AM
Last Post: sashka_amur
  Does this plastic trackpad cover come off? Paulie420 7 1,894 09-17-2020, 02:29 AM
Last Post: KC9UDX
  Mouse drfting when using the trackpad jcarty 1 738 09-15-2020, 03:21 PM
Last Post: ab1jx

Forum Jump:


Users browsing this thread: 1 Guest(s)