[28/03/2017] openSUSE Tumbleweed Images for Pine64
#31
Hello everybody.

I have just released a new openSUSE image based on the latest BSP kernel (3.10.105)

Full changelog:

- Kernel updated to 3.10.105-0-pine64-longsleep-3
- All software has been updated.
- SoPine images are now available

Also, I have enhanced longsleep's build tools to be able to generate openSUSE images (alongside other improvements). The pull request to longsleep's repository is currently under review but if you want to try it out now, you can view it at my repository (https://github.com/Terra854/build-pine64-image/)

As usual, links are in the first post.
Donate BTC: 3Eav9uqXi8Nx1axb7QjK6xV4km4K9YGv9a
  Reply
#32
Thanks for Terra854's work. I can't active the WiFi/Bluetooth module (https://www.pine64.org/?product=wifi-802...4-0-module) with openSUSE revision 28/03/2017 or version 07/12/2016. I tried the following steps.

1. I used the Ubuntu Desktop Image (20161215) with WiFi module, and I can connect to the WiFi. So I think the WiFi module is good.

2. I used the openSUSE image revision 28/03/2017, and followed the steps https://forum.pine64.org/showthread.php?tid=982 without setting the DHCP. After reboot, the WiFi was not automatically connected. The wlan0 appeared after I used the command:

Code:
sudo ip  link  set  wlan0  up
 
and WiFi signals appeared with the command:

Code:
sudo iwlist wlan0 scan

The I try to active the wlan0 (with some messages) by 
Code:
sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf

Successfully initialized wpa_supplicant
nl80211: Could not re-add multicast membership for vendor events: -2 (No such file or dire
ctory)

The output of ifconfig is:
Code:
eth0      Link encap:Ethernet  HWaddr A2:EE:96:E4:54:89  
         inet addr:192.168.10.245  Bcast:192.168.10.255  Mask:255.255.255.0
         inet6 addr: fdd6:752:efa8:0:a0ee:96ff:fee4:5489/64 Scope:Global
         inet6 addr: fdd6:752:efa8::b26/64 Scope:Global
         inet6 addr: fe80::a0ee:96ff:fee4:5489/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:207 errors:0 dropped:0 overruns:0 frame:0
         TX packets:179 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:21407 (20.9 Kb)  TX bytes:20570 (20.0 Kb)
         Interrupt:114

lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:65536  Metric:1
         RX packets:592 errors:0 dropped:0 overruns:0 frame:0
         TX packets:592 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:49136 (47.9 Kb)  TX bytes:49136 (47.9 Kb)

wlan0     Link encap:Ethernet  HWaddr 34:C3:D2:6D:4A:F6  
         inet6 addr: fe80::36c3:d2ff:fe6d:4af6/64 Scope:Link
         inet6 addr: fdd6:752:efa8:0:36c3:d2ff:fe6d:4af6/64 Scope:Global
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:38 errors:0 dropped:0 overruns:0 frame:0
         TX packets:10 errors:0 dropped:1 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:12973 (12.6 Kb)  TX bytes:1215 (1.1 Kb)

the iwconfig outpus is 
Code:
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"mywifi"  Nickname:"<WIFI@REALTEK>"
         Mode:Managed  Frequency:2.462 GHz  Access Point: 6C:B0:CE:E9:E9:7F  
         Bit Rate:150 Mb/s   Sensitivity:0/0  
         Retry:off   RTS thr:off   Fragment thr:off
         Encryption key:****-****-****-****-****-****-****-****   Security mode:open
         Power Management:off
         Link Quality=100/100  Signal level=-58 dBm  Noise level=0 dBm
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0

dummy0    no wireless extensions.

sit0      no wireless extensions.

lo        no wireless extensions.

wlan1     unassociated  Nickname:"<WIFI@REALTEK>"
         Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated  
         Sensitivity:0/0  
         Retry:off   RTS thr:off   Fragment thr:off
         Encryption key:off
         Power Management:off
         Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0
I still can't connect to the WiFi.

3. I imageed a new openSUSE revision 28/03/2017, and tried to use yast.
In YaST2 --> System --> Network Settings, I edited the wlan0 (WLAN controller) information and saved. But the details of wlan0 were:

Code:
WLAN controller (Not connected)                                                
MAC : 34:c3:d2:6d:4a:f6                                                      
BusID : mmc1:0001:1
 
It seemed the wlan0 not active and I can't connect to WiFi.
Note that after the command
Code:
sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf


the wlan0 in the YaST2 changed to
Code:
WLAN controller                                               
MAC : 34:c3:d2:6d:4a:f6                                                      
BusID : mmc1:0001:1

I still can't connect to WiFi.

Welcome any comments and suggestions  Smile.
  Reply
#33
First off, thanks for all your hard work!
I boot up, and log in, but what next?
I'm at pine64@pine64:">

I apologize, but I'm a real newbie.
Dave
  Reply
#34
it appears the desktop did not start for some reason. try entering

reboot

and see if it starts at next boot
  Reply
#35
(04-29-2017, 09:19 PM)dkryder Wrote: it appears the desktop did not start for some reason. try entering

reboot

and see if it starts at next boot

There is no desktop environment installed in my images in order to reduce the size of the image.

If you want to install a desktop, you can run the pine64-config tool and select "Install a Desktop Environment", then follow the instructions.
Donate BTC: 3Eav9uqXi8Nx1axb7QjK6xV4km4K9YGv9a
  Reply
#36
(04-30-2017, 01:31 AM)Terra854 Wrote:
(04-29-2017, 09:19 PM)dkryder Wrote: it appears the desktop did not start for some reason. try entering

reboot

and see if it starts at next boot

There is no desktop environment installed in my images in order to reduce the size of the image.

If you want to install a desktop, you can run the pine64-config tool and select "Install a Desktop Environment", then follow the instructions.

yeah, i remember that now. i did the setup process for the image back in november. damn, being old sucks.
  Reply
#37
I was unable to run pine64-config so I searched and discovered I first need to run "sudo ./install.sh" but it said 'command not found'.
Neither https://forum.pine64.org/showthread.php?tid=1855 nor https://github.com/Terra854/build-pine64-image provided detailed instructions for a newbie.

Do I need to download and write something else to the sd card? I'm not even at a point where I can use the wifi.

Thanks, David
  Reply
#38
try to change directory to usr/local/sbin

cd /usr/local/sbin

and then do

ls -l

and see if those scripts are in that directory , if so try running them again
  Reply
#39
Thanks.
I changed the directory and now I see pine64-config, but it didn't run. I'm thinking I need to run "sudo ./install.sh" but that didn't work from that directory.
  Reply
#40
perhaps you need to set permissions on that file to make it executable. right click on file , select permissioms tab, if box to make file executable is unchecked, check it. if it is checked then i'm stumped on what is next.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  GUI on openSuSE joaoreino 10 5,119 01-23-2018, 09:00 PM
Last Post: tmechanic

Forum Jump:


Users browsing this thread: 1 Guest(s)