Howto: OctoPrint Working on Pine 64
#15
(06-16-2017, 01:00 AM)baldey Wrote: Hi all,

Got the image working on the wireless LAN just fine, but for some reason when I go to install plugins (such as PSU Control) they don't show up on the top menu bar Sad Any ideas/suggestions?  I'd love to put the power of the pine to good use!

Also, the GPIO doesn't seem to function;  I have the RGB LED strip plugin and writing out to the pins doesn't seem to trigger the relay.  This all works fine on my ancient raspberry pi.

I suspect the GPIO problems are related to the pine64 I/Os being numbered differently to the raspberry pi, and possibly permissions errors ... until you can trigger it manually via the terminal will be hard to pin down...

Not sure about the top menu issues... latest version of octoprint (1.3.4 at time of writing)?
  Reply


Messages In This Thread
RE: OctoPrint Working on Pine 64 - by JAYJAYN - 08-28-2016, 12:22 AM
RE: OctoPrint Working on Pine 64 - by dabone - 10-10-2016, 10:41 AM
RE: OctoPrint Working on Pine 64 - by JAYJAYN - 11-18-2016, 06:29 AM
RE: OctoPrint Working on Pine 64 - by dabone - 11-30-2016, 10:53 PM
RE: Howto: OctoPrint Working on Pine 64 - by pfeerick - 06-16-2017, 02:09 AM
RE: Howto: OctoPrint Working on Pine 64 - by jjfs - 09-27-2018, 11:27 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Debian installer on Pine A64+ but no hdmi mrwick 1 3,725 07-28-2020, 01:49 PM
Last Post: kuleszdl
  Captive portal at school not working on the Pinebook pro WilliamZieg 2 3,450 02-06-2020, 10:41 PM
Last Post: xmixahlx
  Q4OS WiFi Dongle not working cheezmeister 3 3,528 04-07-2017, 08:01 AM
Last Post: iccoldbeer
  HowTo working with MPD and analog sound caragk 3 9,882 11-09-2016, 08:44 AM
Last Post: jkmooney
Exclamation JAVA App. not working correct wrongway 0 1,707 09-14-2016, 11:14 AM
Last Post: wrongway
  Anyone got jackd working? jkmooney 4 4,606 08-27-2016, 08:18 AM
Last Post: pfeerick
  32bit Apps on Pine djinn5150 2 3,442 08-09-2016, 11:03 AM
Last Post: xalius
  Can ping between Pine 64 on a switch, but unable to ssh MikeJewski 4 4,586 07-28-2016, 08:40 PM
Last Post: MikeJewski
  Internet not working properly cezar.suteu@gmail.com 2 3,136 06-17-2016, 01:12 AM
Last Post: cezar.suteu@gmail.com
  wget not working? slerched 3 4,052 06-01-2016, 08:15 AM
Last Post: slerched

Forum Jump:


Users browsing this thread: 1 Guest(s)