Help with Kali Linux wifi not working but works with Manjaro
(05-27-2022, 10:24 PM)PineSupporter Wrote: Hello,

I usually use PBP with Manjaro and everything works great.  I recently flashed Kali on SD card but for some reason it's not connecting to wifi.  I'm still very new to Linux.  I tried searching online for the answer but can't seem to find it.
I ran airmon-ng command and this is what I got:

phy0      wlan0     brcmfmac        unable to detect for sdio 0x02d0:0xa9bf

Does anyone know what's wrong and how I can connect my wifi?

I had a similar issue (I am not sure it is the same issue but who knows, it could help some people).
In my case, as I understand it (I may be wrong), the issue seemed to be caused by a different wireless card in the new pinebook-pro of 2022 compared to the previous one (I don't know about your version of the pinebook since you posted in May).
In my case, I could see the origin of the issue by typing in a terminal:
sudo dmesg | grep brcm
I saw some lines that contained words like "firmware:" and "failed to load". At some point (as I understand it), the driver for the Broadcom wireless card will ask udev for a firmware, in order to flash it in the Broadcom chip. It fails because the requested firmware is not present.
By the way the "dmesg" command seems really useful for beeing aware of failures that can happen when the kernel is booting. And it is not specific to Debian, so the command should be available on any linux distribution I guess.

The issue has been reported here and a fix was created.
I am not sure if the fix is already included in the kali release image from here or not yet.

Since I had already installed kali, I prefered fixing it without reinstalling it. Here is what I did.
I downloaded the missing files from gitlab:
And I copied them into the filesystem of my kali installation inside the folder: "/lib/firmware/brcm"

Then, after a shutdown and a restart, I could connect to wifi networks.

I hope it will help some of you.

Messages In This Thread
RE: Help with Kali Linux wifi not working but works with Manjaro - by Niko - 08-25-2022, 02:15 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  WiFi stopped on Pinebook Pro after update tkudog 3 322 11-24-2022, 04:32 PM
Last Post: tkudog
  Pinebook Pro wifi not working Queliffrel 0 53 11-22-2022, 01:20 PM
Last Post: Queliffrel
  Kali Linux for Pinebook Pro Luke 95 109,262 11-22-2022, 12:46 AM
Last Post: Tazdevl
  DiY - Installing Void Linux ARM On The Pinebook Pro vincele 0 74 11-21-2022, 09:57 AM
Last Post: vincele
  Archlinux - missing firmware for wifi adapter RudderDuck 9 919 11-07-2022, 04:56 PM
Last Post: wgahnagl
  Resume from suspend not working after flashing Tow-Boot to SPI xp19375 3 242 10-31-2022, 10:14 AM
Last Post: wdt
  PineBook Pro-Problems with ARCH-Manjaro. Ice-O-Star 0 228 10-22-2022, 10:46 AM
Last Post: Ice-O-Star
  newer ""emmc-installer" images (manjaro xfce) magistral 1 269 10-10-2022, 06:22 AM
Last Post: maxjrh
  Webcam not working in Manjaro with Cheese, but works in Armbian petaramesh 1 240 09-30-2022, 10:09 AM
Last Post: crazyquark
  Arch Linux ARM root filesystem SKiljan 24 11,809 09-24-2022, 03:11 AM
Last Post: alexandre

Forum Jump:

Users browsing this thread: 1 Guest(s)