RaZberry Module (z-wave) need support to get it working!
#8
So I'm still confused..
Here is a screenshot of my /dev
https://www.dropbox.com/s/tolzoxm7k1zrt5...0.png?dl=0
I don't see anything that looks like the razberry

Could it be ttyS0 or tty0 ?
Should I remove this line /boot/uEnv.txt?
console=tty0 console=ttyS0,115200n8 no_console_suspend

Update:
Code:
traceback (most recent call last):
  File "/usr/local/lib/python3.5/dist-packages/openzwave-0.3.1-py3.5.egg/openzwave/option.py", line 69, in __init__
    raise ZWaveException(u"Can't write to device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: "Zwave Generic Exception : Can't write to device /dev/tty0 : ['NoneType\\n']"

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.5/dist-packages/homeassistant/bootstrap.py", line 157, in _setup_component
    if not component.setup(hass, config):
  File "/usr/local/lib/python3.5/dist-packages/homeassistant/components/zwave.py", line 200, in setup
    default_zwave_config_path),)
  File "/usr/local/lib/python3.5/dist-packages/openzwave-0.3.1-py3.5.egg/openzwave/option.py", line 75, in __init__
    raise ZWaveException(u"Error when retrieving device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: 'Zwave Generic Exception : Error when retrieving device /dev/tty0 : [\'Traceback (most recent call last):\\n\', \'  File "/usr/local/lib/python3.5/dist-packages/openzwave-0.3.1-py3.5.egg/openzwave/option.py", line 69, in __init__\\n    raise ZWaveException(u"Can\\\'t write to device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))\\n\', \'openzwave.object.ZWaveException: "Zwave Generic Exception : Can\\\'t write to device /dev/tty0 : [\\\'NoneType\\\\\\\\n\\\']"\\
Same error with ttyS0

What I else I did was
sudo usermod -a -G tty ubuntu
sudo usermod -a -G dialout ubuntu


Still not sure what I do wrong :/
  Reply


Messages In This Thread
RE: razberry (z-wave) .. does it works with pine? - by Luxus - 06-28-2016, 03:59 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
Question Z-Wave module pinout to make it compatible with Pi b+ ebretteville 59 61,278 07-12-2019, 08:55 AM
Last Post: kris240376
Question RGB LED Matrix support? foxnox 1 3,262 12-29-2017, 06:52 PM
Last Post: psychedup
Sad Z-Wave and openzwave+node-openzwave-shared saro 2 4,911 09-01-2017, 05:22 AM
Last Post: saro
Question Is SPI Working? ericnhitterdal@gmail.com 64 70,219 08-12-2017, 03:14 PM
Last Post: louwie17
  Z-Wave - Full and Low Power Inclusion mode B34N 1 3,252 03-26-2017, 06:03 PM
Last Post: B34N
  KICAD Quick Lib and Module Generator mbt28 1 3,592 02-12-2017, 10:45 PM
Last Post: tllim
  Z Wave Module and still using GPIO bang 2 4,425 01-16-2017, 03:12 AM
Last Post: bang
  Z-Wave US module with adapter aegrotatio 4 5,397 01-08-2017, 12:03 AM
Last Post: aegrotatio
  Dallas 1-Wire Support ItsDave 31 26,532 12-27-2016, 08:30 PM
Last Post: ed_mann
  touch screen not working mike280z 1 2,844 12-22-2016, 12:46 PM
Last Post: Bluphire

Forum Jump:


Users browsing this thread: 1 Guest(s)