3 Boards, only one boots
I just received a series of RP64 units from AmeriDroid.

I placed one into the NAS case with Armbian on a 32GB eMMC chip.  Boots properly and finalizes the install.  Ran through updates and all seems well.

Moved the eMMC chip to the second board - nothing but the green power LED on power up.

Moved the eMMC chip to the third board - nothing but the green power LED on power up.

I've attempted the POWER-RESET gambit on both non-booting boards.

I've returned the eMMC chip to the first board and all is fine.

Removed the boards from the NAS enclosures, same result.

Burned a 32GB µSD card with the same Armbian image and jumpered the eMMC disable jumper

Still power LED, but nothing else.

Are there some bad boards out there?
Hi timinal and welcome to the forum,
   thist behaviour is very strange indeed. Basically there is no problem moving the chip from a card to another. The only difference may come from the spi flash of the board,which should not affect the boot itself. But I suppose you did not flash them except eventually for the nas. You could eventually check with an UART if the boot process properly occurs.
I have exactly the same problem with two brand new Pine64 boards.  I note also, that the USB ports don't power up either, the LED mouse doesn't light up.

Help, this is frustrating.  How could I have two bad boards??


Matt Dralle
I ordered a "Rockpro64 v2.1 2018-07-02" board and recommended power supply in December 2021 and it has never booted.  I am seeing the same symptoms:
* Green power LED lights.
* RJ45 jack LEDs light, one green, one orange.
* No other LED lights up.
* No power enabled on any USB port.

There is no activity on the serial port UART2_TX as observed by a USB to 3.3V TTL adapter and minicom:
$ /usr/bin/minicom -D /dev/ttyUSB0 -b 1500000

Additionally I have watched UART2_TX (expansion port pin 8) with an oscilloscope and there is no activity.  The output is steadily high, except while holding the reset button when it is steadily low.

UART2_RX is unconnected.

I have tried Armbian, DietPi, Manjaro, and Open Media Vault.  I am writing the SD card like this:
$ sudo dd if=Armbian_21.08.1_Rockpro64_focal_current_5.10.60.img of=/dev/mmcblk0 bs=1M

I have tried booting with and without expansion port pins 23 and 25 shorted to disable the SPI boot.

Is there anything else to try, or should I get an RMA? 
Thank you for your help.
Other than trying an alternative power supply it sounds like a faulty board. If you have an alternative power supply try that, otherwise I'd return the faulty board.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Number of Rockpro64 boards sold/made fentavius 1 2,029 09-16-2019, 10:53 AM
Last Post: tllim

Forum Jump:

Users browsing this thread: 1 Guest(s)