Has anyone gotten "reset" to work in U-Boot for Pine64?
Has anyone gotten the "reset" command to work in U-Boot (v2021.01) for Pine64?

I've tried for days combinations of enabling and disabling PSCI, SYSRESET, and DM_RESET. I've applied and removed various reset patches from people like Chris Blake in 2017 and again in 2019.

Either the SoC enters an infinite loop walking a DM tree, or a message stating reset isn't supported on the board.

Let's not ask what combination of CONFIG_* flags I've set, because I've tried permutations of them all.

Has anyone, anywhere, gotten the SoPine (on a clusterboard) or Pine64-LTS to actually restart as if the reset button had been pressed? What are your defconf settings? What version in U-Boot? Thx!

Possibly Related Threads…
Thread Author Replies Views Last Post
  power usage for Pine64 LTS + Screen Little_Johnny 1 352 02-17-2021, 07:19 PM
Last Post: Little_Johnny
  Pine A64 LTS V1.2 LCD DSI Boot Issue emud 1 1,088 08-08-2020, 11:29 AM
Last Post: emud
  Pine64 LTS GbE Problem scchoi 1 1,166 06-20-2020, 12:39 PM
Last Post: tllim
  Mainline u-boot FEL failure foreverska 0 998 12-19-2019, 10:21 AM
Last Post: foreverska
  Selling my Pine64 2gb LTS with a bunch of accessories poponon 0 778 08-08-2019, 09:01 PM
Last Post: poponon
  change the charge LED indicator to Mode B on Pine64 LTS JTX 0 785 04-12-2019, 06:34 PM
Last Post: JTX
  Sopine baseboard CSI port camera not work olivaw 2 1,328 02-20-2019, 09:50 AM
Last Post: maya.b
  Pine64 LTS Boot Media order Akash Gajjar 1 1,209 07-22-2018, 05:29 PM
Last Post: tllim
  Pine64 LTS Not booting krisclarkdev 2 1,439 05-13-2018, 10:22 PM
Last Post: krisclarkdev
  Pine64 LTS - DOA harcrow 8 2,702 03-30-2018, 02:13 PM
Last Post: davidgs

Forum Jump:

Users browsing this thread: 1 Guest(s)