Graphical login hanging after password entry
#1
I'm using the stock Manjaro install.  I got things set up fairly well about a month ago, but haven't had time to get it out for a few weeks.  A day or two ago I powered it on, and entered my password at the graphical login screen as usual.  When I hit Enter or click the Login button, it turns solid green and then freezes that way.  The mouse pointer still moves around in response to the trackpad, but everything on the screen is unresponsive from that point on.  Fortunately, I can restart it with Ctl-Alt-Backspace.

Login on the alternate consoles is unaffected.  The only process running on tty1 is Xorg.

I discovered that after enough attempts, and maybe changing the session manager from the list in the lower left corner, I can finally succeed in logging in.  Sometimes it's after a dozen tries, though.

I had not changed any packages since the last time it worked normally.  I rebooted several times, but no change.  I applied all the software updates (200+) and rebooted.  Still does the same thing.

Does anybody have any clues what might be going on, or how to debug further?

TIA for any suggestions.
M Hill
Pinebook Pro owner since 2020/08
  Reply
#2
(10-13-2020, 06:56 PM)mhill8 Wrote: I'm using the stock Manjaro install.  I got things set up fairly well about a month ago, but haven't had time to get it out for a few weeks.  A day or two ago I powered it on, and entered my password at the graphical login screen as usual.  When I hit Enter or click the Login button, it turns solid green and then freezes that way.  The mouse pointer still moves around in response to the trackpad, but everything on the screen is unresponsive from that point on.  Fortunately, I can restart it with Ctl-Alt-Backspace.

Login on the alternate consoles is unaffected.  The only process running on tty1 is Xorg.

I discovered that after enough attempts, and maybe changing the session manager from the list in the lower left corner, I can finally succeed in logging in.  Sometimes it's after a dozen tries, though.

I had not changed any packages since the last time it worked normally.  I rebooted several times, but no change.  I applied all the software updates (200+) and rebooted.  Still does the same thing.

Does anybody have any clues what might be going on, or how to debug further?

TIA for any suggestions.
Are you using mesa-git by any chance?  The last two versions of it caused kwin to hang (I managed to get in the second time, but maybe yours doesn't).  If that's the case, it's an easy fix.  Just follow the instructions in this thread: https://forum.pine64.org/showthread.php?tid=11598
  Reply
#3
Because X is running on tty1, but not on tty2. A tty is a "virtual terminal", meaning it is supposed to represent an actual physical screen and keyboard, etc. The terminals are all on simultaneously, but since you only have enough hardware to interface with one at a time, that's what you get.
You can in fact run multiple X sessions on different ttys and switch between them. You need a valid ~/.xinit or ~/.Xclients first. If you don't, for illustration:

just try this and thanks me later

echo -e "#!/bin/sh\n mwm" > ~/.xinit
chmod u+x ~/.xinit

If there isn't a display manager doing something totalitarian, you should get a plain black window with a big X mouse cursor. Left clicking should give a crude looking menu from which you can now "Quit"; but before that CtrlAltF1 will take you to the other X session on tty1 (and F2 gets you back, etc.).

___________________________________
Gordon Bullard & Company
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  pinebook pro wiki link on the website links to the wrong wiki entry Julius_GU 0 201 02-11-2021, 10:27 AM
Last Post: Julius_GU
  Forgot my Pinebook password. Booting from MIcroSD doesn't work. ksfoodforest 0 238 01-30-2021, 11:08 AM
Last Post: ksfoodforest
  PBP Went Blank After Login iscmob 2 575 12-07-2020, 09:28 AM
Last Post: iscmob
  Pinebook Pro Won't Accept Login GFreeman 16 4,350 09-03-2020, 11:44 AM
Last Post: wdt
  [split] Change password from external media James Good 11 3,623 07-23-2020, 02:42 PM
Last Post: wdt
  Login screen issue. LinuXchoicE 2 1,188 07-07-2020, 09:06 AM
Last Post: LinuXchoicE
  Stuck on login screen Kscott6969 0 729 04-20-2020, 10:58 PM
Last Post: Kscott6969
  PBP Complete Loss of Password Recognition jcj52436999 2 1,077 03-16-2020, 05:38 PM
Last Post: jcj52436999
  default os: loop while login as rock gritibaenz 8 3,125 03-10-2020, 03:14 PM
Last Post: gritibaenz
  Password change RedHaoredOmen 18 4,839 03-01-2020, 12:27 PM
Last Post: mainer

Forum Jump:


Users browsing this thread: 1 Guest(s)