Correct setup for u-boot and fstab ? Device not booting
I am trying to boot from eMMC and no I did not flash uBoot into SPI and everything is on the same card, but divided in 3 partitions (boot=ext2 / root=ext4 / swap)

My extlinux.conf is as below
DEFAULT debian

LABEL debian
KERNEL /vmlinuz
INITRD /initrd.img
APPEND console=tty1 root=LABEL=root rw rootwait

I have not tried to boot from SD-Card, will do next week when I have more time on hand.
Do you have some strange characters in the file or something similar? The contents itself look okay to me. Did you change something in u-boot when compiling it such as removing support for extlinux or the like? At least these messages seem to indicate that uboot does not know what the commands in the extlinux.conf mean:

Retrieving file: /extlinux/extlinux.conf
191 bytes read in 2 ms (92.8 KiB/s)
Ignoring unknown command: MENULABEL
Ignoring unknown command: KERNEL
Ignoring unknown command: INITRD
Ignoring unknown command: DEVICETREEDIR
Ignoring unknown command: APPEND

One thing you could try would be entering the relevant commands by hand on the command line and see if it boots then for you.
Tried with an SD-Card and it behaves exactly the same, won't parse extlinux.conf.

I have checked the file in nano and could not see any strange symbols or similar, only plain text.

And I use stock u-boot without any modification, direct from source/github.

@as365n4 That's really strange. Did you try with an older uboot version as well? I will try to reproduce the issue once I free my eMMC module (I currently use it on my rockpro64 but plan to switch to microSD this weekend).
@as365n4 I just tried with the latest build I just finished (using Debian instead of Devuan this time). No issues with u-boot, it just boots fine (tried using eMMC). Would it help if I send you my u-boot image?
sorry for the late reply, I was busy with work all February... Undecided

I just downloaded the sources again for arm-trusted-firmware and uboot.
Tha arm-trusted-firmware built just fine without errors (v2.4).
But the u-boot built finished with an yellow error, as below (v2021.01), could this the reason why my built of u-boot wont decode extlinux.conf ?

Image 'main-section' is missing external blobs and is non-functional: scp

   SCP firmware is required for system suspend, but is otherwise optional.
   Please read the section on SCP firmware in board/sunxi/README.sunxi64

Some images are invalid

And many thanks for your offer in sending your u-boot image, but I would like to crack that nut and manage to build a working u-boot.
Main goal is to provide a "simple to follow" guide to build Debian for H64 Boards and publish that on Github for others to use who might be interested. Wink
As I believe the H64 doen't get enough "love" from the wider Linux Community / Distros.
You are welcome. :-)

And no, I don't remember getting this error. Maybe it would help if I record a small asciinema screencast when building u-boot, probably we will be able to find the difference this way faster.

@as365n4 I tried it again, and indeed newer u-boot versions seem not to work for the H64. But v2020.10 does. See my recording here (including the failed attempts):

(recording will be auto-deleted after 7 days)

Possibly Related Threads…
Thread Author Replies Views Last Post
  Unable to boot any armbian linux vicsanca 6 2,367 10-17-2019, 12:08 PM
Last Post: JGwinner

Forum Jump:

Users browsing this thread: kuleszdl, 1 Guest(s)