I/O errors from SD card slot? (Manjaro, kernel 5.7)
#1
I'm getting I/O errors from some, but not all, attempts to use the SD card slot in my PBP.  `badblocks -w /dev/mmcblk1` completes without error, and `fdisk` is also happy, but when I attempt to run `mkfs.ext4` or `cryptsetup luksFormat` on the (single, whole-disk) partition, the operation fails and I see errors like this in dmesg:

Code:
blk_update_request: I/O error, dev mmcblk1, sector 2120 op 0x1:(WRITE) flags 0x8800 phys_seg 255 prio class 0
blk_update_request: I/O error, dev mmcblk1, sector 2128 op 0x1:(WRITE) flags 0x8800 phys_seg 254 prio class 0
blk_update_request: I/O error, dev mmcblk1, sector 2117 op 0x1:(WRITE) flags 0x8800 phys_seg 255 prio class 0
blk_update_request: I/O error, dev mmcblk1, sector 2127 op 0x1:(WRITE) flags 0x8800 phys_seg 255 prio class 0

(Only one error occurred per attempt to format the partition.)

I put the card into a different computer and was able to create a filesystem successfully, so I don't think the card itself is at fault. However, when I put the formatted card back into the PBP and tried to mount the filesystem or to run e2fsck on it, I got more of the same errors, just with different sector numbers and flags:

Code:
blk_update_request: I/O error, dev mmcblk1, sector 8301 op 0x1:(WRITE) flags 0x8800 phys_seg 251 prio class 0
blk_update_request: I/O error, dev mmcblk1, sector 40960 op 0x1:(WRITE) flags 0x800 phys_seg 1 prio class 0
blk_update_request: I/O error, dev mmcblk1, sector 59023360 op 0x1:(WRITE) flags 0x800 phys_seg 1 prio class 0

This is a 2019-batch PBP, so it shipped with MrFixit's modified Debian, and the card slot was working fine with that kernel; I only started seeing problems after I reflashed the internal storage with Manjaro. So right now I'm inclined to suspect a kernel bug. Anyone else seeing similar problems? Workarounds? Debugging advice?


Messages In This Thread
I/O errors from SD card slot? (Manjaro, kernel 5.7) - by zackw - 07-16-2020, 07:31 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Cannot Boot From SD Card xp19375 4 328 11-12-2022, 11:26 AM
Last Post: KC9UDX
  Manjaro pinebookpro images with kernel 5.7.19 rfm83 10 936 10-11-2022, 12:20 AM
Last Post: rfm83
  Broken usb-c to hdmi with kernel 5.18+ rfm83 5 562 10-10-2022, 12:10 PM
Last Post: rfm83
  No boot after Manjaro flash PBcurry 14 1,192 10-03-2022, 08:33 PM
Last Post: wdt
  Can't boot when SD card inserted 0daysfordays 3 533 09-17-2022, 06:59 PM
Last Post: wdt
  minimal kernel .config? alchemist 5 4,072 08-15-2022, 06:28 PM
Last Post: svmhdvn
Big Grin EASY SOLUTION for Manjaro "Missing Keys" Update and Install Failure Zoroaster-Z 0 735 08-14-2022, 09:01 PM
Last Post: Zoroaster-Z
  Manjaro ARM new version? And hibernate/ sleep mode regretfulpineuser 0 387 06-20-2022, 02:48 PM
Last Post: regretfulpineuser
  MAC Spoofing failing in manjaro slow_motion 7 6,078 06-07-2022, 05:51 PM
Last Post: regretfulpineuser
  Problem SD card willahughes 1 767 03-22-2022, 09:27 AM
Last Post: jiyong

Forum Jump:


Users browsing this thread: 1 Guest(s)