RockPro64 eMMC boot
#1
First tries with my new RockPro64.

Flashed Manjaro ARM 20.06 on an SD card and ayufan's latest stable release bionic-minimal-rockpro64-0.9.14-1159-armhf on another SD card.
Both of them work just fine.

While in Manjaro, I flashed the same Manjaro image to eMMC, which Linux sees as /dev/mmcblk1.
Shutdown, removed SD card and reboot.
The board does not boot from eMMC.
It boots fine from Manjaro SD card when eMMC module is present.

Tried the same thing in Bionic, flashing the same Bionic image to eMMC.
Again the board does not boot from eMMC, but boots all right from Bionic SD card with the eMMC module present.

Then I flashed the SPI using the instructions from https://github.com/ayufan-rock64/linux-b...ash-spi.md with the latest release of flash_spi.img.
The eMMC module was removed during the SPI flashing process.
Same result, the board still does not boot from eMMC.

Last thing I flashed the SPI again using the instructions from https://github.com/sigmaris/u-boot/wiki/...oot-to-SPI.
This did not help either: boot from eMMC is not happening, while boot works like a charm from any SD with the eMMC present.

SW4 is open (no jumper).

What am I doing wrong?
How do I get the board to boot from eMMC?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 40 5,668 07-13-2020, 12:08 PM
Last Post: Bullet64
  ROCKPro64 has Lithium Battery Port yes or no? anfast 3 213 06-25-2020, 02:09 PM
Last Post: anfast
Music Need Direction with my Rockpro64 RachelMusclegirl 4 313 06-11-2020, 12:12 PM
Last Post: Der Geist der Maschine
  Performance and Power Demand RockPro64 fotastisch 6 693 06-06-2020, 03:27 PM
Last Post: Atch
  RockPro64 so problematic! Boot issues PorterDon 1 217 06-04-2020, 12:25 PM
Last Post: dukla2000
  RockPro64 Power input m.ekstrom 0 123 05-19-2020, 03:28 AM
Last Post: m.ekstrom
  Failure to boot atcwells 1 193 05-10-2020, 03:06 PM
Last Post: atcwells
  RockPro 64 V2.1 Boot problem only DDR Version ... message nutilius 5 581 05-02-2020, 03:26 AM
Last Post: freeviv
  RockPro64 intermittent freezing Servingworlds 1 153 04-26-2020, 02:21 PM
Last Post: mabs
  No /dev/gpiochip[n] on RockPro64. Faradn 6 392 04-21-2020, 08:03 AM
Last Post: Faradn

Forum Jump:


Users browsing this thread: 1 Guest(s)