Pinebook Pro totally dead
My PBP appears to have completely crapped itself.

It was working fine for a long time. This evening, I turned it on, not realizing that the battery had drained to nothing. It made it to the login screen fine, I saw that it was basically dead, and rushed to plug it in. Before I could get there, it died. So I plugged it in via USB (it looked to be charging fine), waited a good half an hour and turned it back on, still connected to USB.

It booted up, went to the login screen, but as soon as I logged in, the entire screen glitched out and went almost entirely white, with some tearing. It did not resolve itself after a couple minutes, and was completely unresponsive, forcing me to do a hard reset. It turned off, and now will not turn on whatsoever. No boot screen, no power light, no screen backlight, nothing.

What I have tried:
  • Booting from SD card
  • Turning off eMMC and again booting from SD
  • Reset button
  • Recovery button
  • Using a different eMMC module
  • reflashing the original eMMC module
Nothing has produced any results. Is it just toast?
Have you tried disconnecting the battery and use the bypass cables?

Someone else responded in this thread and had to boot from micro SD, as it seems the image on the eMMC was corrupted.
I found it in this thread:
Since you drained the battery that far, you're going to need to give it more time to charge, like a few hours. If it's deeply discharged it can take overnight.

Don't fret, don't worry about trying all those other methods, b/c they won't directly help. Just plug in the PBP and walk away for a while. The bypass cables are not a good solution to your issue, either. The battery just needs to charge, and it needs more time than most consumer laptops, b/c the charging rate is much lower than say x86 laptops.
So, I plugged it in overnight as suggested, and it turns out that both of you were partially right.

When I tried turning it on this morning after what had seemed to be a decent charge (the charging light was still blinking), it still refused to turn on. So I gave in to frustration, disconnected the battery, hooked up the bypass cables, and plugged it in to the DC power supply. Everything turned on immediately and just fine. All of this leads me to believe that there might be something up with charging via USB-C, as that was what I had it hooked up to last night. The cable is good, the power supply is good, the PBP seems to *think* it's being charged, but if so, what was it doing for 10 hours last night that led to it not having any power today?

In any case, I have a partial solution now. Until I can figure out if there's something wrong with the USB-C port or charging via it, the normal DC charging will have to do. Thanks to both of you!
Good to hear you were able to revive it in some way.
This kind of behaviour is not uncommon.
I also have it with an old Samsung 7.7 tablet and a Lenovo Yoga tablet.
Once their batteries get to a very low charge state, I can only revive them with the original charger.
When in normal state, I can use any charger I like (with the correct connector).

I guess that some batteries need some sort of kick start to come out of the low charge state.
And I wouldn't be surprised when the Pinebook Pro only accepts 5V on the USB-C port, although the USB-C standard does allow higher voltages (and currents).
I once took apart (and demolished) a tablet that was dead as it didn't charge anymore. It was my first USB-C device.
Later, when I got another USB-C device, I wanted to charge that with the old cable that came with the tablet and it turned out that the power coming out of the cable was nothing more than a leak-current.

I had destroyed my tablet because of a bad cable... Sad

Now I have several USB-C devices, chargers and cables. Not every cable works as well it seems. Also a charger that is able to handle 3A is nice to have as some of my devices show irratic behaviour on 1,5 to 2A chargers. I have one of such 3A adapters and it works on every device I have Smile

Possibly Related Threads…
Thread Author Replies Views Last Post
Question High Pitch Noise Coming From Pinebook Pro Feakster 59 55,731 09-25-2022, 03:34 AM
Last Post: crazyquark
  Use SD to install new OS over pinebook debian Rudy558 10 4,026 09-25-2022, 01:19 AM
Last Post: jackwilson
  Pinebook Pro freezes when running on battery petaramesh 5 199 09-22-2022, 12:43 AM
Last Post: petaramesh
Question Inquiring about the PineBook Pro Taiwanese Independence 0 139 09-09-2022, 08:13 PM
Last Post: Taiwanese Independence
  Pinebook Pro won't boot Whisk 4 314 09-03-2022, 07:43 PM
Last Post: KC9UDX
  alarming sound coming from pinebook pro jazzhands 2 304 08-21-2022, 02:34 PM
Last Post: foobar
  Pinebook Pro Initial Impressions kunger 433 413,963 08-21-2022, 01:45 AM
Last Post: LivingLinux
  WTB Pinebook Pro ANSI/ISO kreyren 0 151 08-21-2022, 01:41 AM
Last Post: kreyren
  Prepare Pinebook Pro for Sale GFreeman 11 2,793 08-21-2022, 01:23 AM
Last Post: kreyren
Rainbow US Ansi Pinebook Pro for Sale loblolly 1 212 08-21-2022, 01:22 AM
Last Post: kreyren

Forum Jump:

Users browsing this thread: 1 Guest(s)