Sata HD stopped booting
#1
I have a RockPro64 running Ubuntu 4.4.190-1233-rockchip-ayufan-gd3f1be0ed310. It boots from emmc and has a hard disk attached via SATA.

After working fine for a long time, since last week the hard disk doesn't seem to be recognized. It doesn't show up in `fdisk -l` for example and isn't mounted anymore.

If I plug it into another laptop the drive mounts and is visible so I don't think it's dead. dmesg contains `PCIe link training gen 1 timeout!` which may be related and the last time it successfully mounted the linux-firmware package was updated via apt from 1.187.25 to 1.187.26. The older version no longer seems to be available to rollback to so unsure if related.

Anybody seen this before or know what to do here?
  Reply
#2
(03-10-2022, 05:11 PM)db579 Wrote: I have a RockPro64 running Ubuntu 4.4.190-1233-rockchip-ayufan-gd3f1be0ed310. It boots from emmc and has a hard disk attached via SATA.

After working fine for a long time, since last week the hard disk doesn't seem to be recognized. It doesn't show up in `fdisk -l` for example and isn't mounted anymore.

If I plug it into another laptop the drive mounts and is visible so I don't think it's dead. dmesg contains `PCIe link training gen 1 timeout!` which may be related and the last time it successfully mounted the linux-firmware package was updated via apt from 1.187.25 to 1.187.26. The older version no longer seems to be available to rollback to so unsure if related.

Anybody seen this before or know what to do here?

Not sure how familiar you are with Linux but a bit of googling should yield some answers. In the meantime have a read up on this https://www.maketecheasier.com/downgrade-kernel-linux/
  Reply
#3
(03-10-2022, 08:42 PM)Rocklobster Wrote:
(03-10-2022, 05:11 PM)db579 Wrote: I have a RockPro64 running Ubuntu 4.4.190-1233-rockchip-ayufan-gd3f1be0ed310. It boots from emmc and has a hard disk attached via SATA.

After working fine for a long time, since last week the hard disk doesn't seem to be recognized. It doesn't show up in `fdisk -l` for example and isn't mounted anymore.

If I plug it into another laptop the drive mounts and is visible so I don't think it's dead. dmesg contains `PCIe link training gen 1 timeout!` which may be related and the last time it successfully mounted the linux-firmware package was updated via apt from 1.187.25 to 1.187.26. The older version no longer seems to be available to rollback to so unsure if related.

Anybody seen this before or know what to do here?

Not sure how familiar you are with Linux but a bit of googling should yield some answers. In the meantime have a read up on this https://www.maketecheasier.com/downgrade-kernel-linux/

@Rocklobster  thanks very much for the hint. I'd completely missed that there was a kernel upgrade in there as well. Downgrading was slightly different than in your link since it's u-boot rather than grub I commented the running kernel out of `/boot/extlinux/extlinux.conf` and rebooted and the drive is mounted again fine.

So it seems `4.4.167-1213-rockchip-ayufan-g34ae07687fce` works fine but ` 4.4.190-1233-rockchip-ayufan-gd3f1be0ed310` does not.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Booting my RockPro64 from NVMe drive PsySc0rpi0n 4 3,068 05-11-2022, 02:35 PM
Last Post: PsySc0rpi0n
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 103 69,961 07-08-2021, 04:55 PM
Last Post: Mentaluproar
Exclamation need help booting off USB 3.0 HDD/SSD idontgetit 1 2,150 10-29-2020, 04:50 AM
Last Post: t4_4t
  Rockpro64 with PCI FC Card - Not booting (Sometimes) MSteam 1 1,998 10-25-2020, 07:42 PM
Last Post: MSteam
  fan continously runs on kernel 5.8 but I need to use 5. kernel for PCIe sata card GreyLinux 4 3,812 10-20-2020, 10:52 AM
Last Post: GreyLinux
  RockPro64 SSD Expansion Board/SATA Shield as0zial 5 5,144 10-18-2020, 08:05 PM
Last Post: revoman
  4pin Connector for dual SATA m.ekstrom 4 4,347 07-28-2020, 07:07 AM
Last Post: mabs
  Defective? PCI-E -> SATA card no work good unregisteredidiot 11 10,132 02-19-2020, 09:08 AM
Last Post: fysa
  RockPro64 not booting jekohk 10 8,732 06-09-2019, 01:53 PM
Last Post: Davidos
  Problems with booting nJoy. 1 1,872 03-23-2019, 03:36 AM
Last Post: nJoy.

Forum Jump:


Users browsing this thread: 1 Guest(s)