Can't find "-" on the keyboard - Printable Version

+- PINE64 (
+-- Forum: PinePhone (
+--- Forum: PinePhone Hardware (
+--- Thread: Can't find "-" on the keyboard (/showthread.php?tid=16681)

Can't find "-" on the keyboard - gilwood - 05-19-2022

I have tried all the left Shift + Fn + all the F1-F10 keys and cannot find a "-". The use of F5 or F6 produce the "~". The use of F7 or F9 produce the "_". The use of the F8 or F10 produce the "+". Finally, the use of F1 or F2 produce the "|". Everything else on the keyboard appears to work as well as the charging and disconnect of my pinephone from charging using the keyboard battery. Am I overlooking something and why is there redundancy in some of the symbols produced using the F keys? Any help is appreciated. Thanks

RE: Can't find "-" on the keyboard - tecdroid - 06-05-2022

Got the same problem. It should be PINE + 5 but doesn't work

debugging via
xkbcli interactive-wayland

showed me that Pine Key (SUPER_L) reacts with any key but not the upper row.
I know that it worked using user space driver but pinephone_keyboard but after last os upgrade I didn't get ppkb to work..

Maybe there's a bug in pinephone_keyboard driver?